memory issue

Trevor

Member
Location
Morecambe
Hello Martin,
I have encountered a memory issue when attempting to wrap a shape along the control template.
I was able to do this previously on the machine in question.It has 8GB of actual memory and 4GB of swap space being a linux machine.
I assume this could be due to all the new additions for 3D printing and machining you have introduced.
Is it possible to turn something off when not required?
Regards
Trevor

error.png
 
_______________
message ref: 2800

Martin Wynne

Admin
Location
West of the Severn UK
Info
Please do not send requests for help direct to me via email.

Post your questions on the forum where everyone can see them and add helpful replies.
@Trevor

Hi Trevor,

This is tricky. If it's on Linux I assume you are using Wine. It could be a problem anywhere, I would hardly know where to start looking. Do you have any means of trying it on a Windows system?

The latest changes for the chairs and 3-D stuff shouldn't make any difference if you are not actually using them.

The wrapping function needs masses of memory space, and also free space on the disk where Templot is installed for temporary files.

The first thing to try would be to select the picture shape and click this button:

to_24bit.png


In the olden days it was preferable to use monochrome images or low colour depth for picture shapes, but modern systems are optimised for full colour, and don't work so well on other formats.

If still no joy, perhaps you could post your BGS3 and BOX files here, and I will try them on my Ubuntu/Wine system and see if I can find the problem.

cheers,

Martin.
 
_______________
message ref: 2804

Trevor

Member
Location
Morecambe
Hello Martin,
I tried your suggestion but was unsuccessful.
Please see the attachment. I am using Wine on Linux. The image I am attempting to wrap along the control template ironically was actually created as a straight image from a wiggly original back ground image with Templot a long time ago.
I should also say the background image takes quite a while to load. I do not recall it taking any time at all when I first used it all those years ago. My BGS3 and BOX file appear to have taken on a life of their own. I do not appear to b able to save and therefore send them.
I may be away some time. :)
 

Attachments

  • error2.png
    error2.png
    544.7 KB · Views: 10
_______________
message ref: 2805

Derek

Member
Location
UK, Midlands
Hello Trevor
If it's any help, you can send the BMP to me with a bit of detail about what you're trying to do and I'll see if I can do it on my windows system. It's a similar spec and might help at least determine whether it's a 'wine' issue or something else.

Derek
 
_______________
message ref: 2808
Top